collapse

* Who's Online

  • Dot Guests: 2
  • Dot Hidden: 0
  • Dot Users: 3
  • Dot Users Online:

* Recent Topics/Posts

Old Dutch sim pilot by salaxi54
[May 22, 2022, 12:06:22 AM]


Hello everyone! by Maxx_6dof
[May 20, 2022, 08:07:31 PM]


Help with New MEMBER REGISTRATION by TacticalRealtor
[May 18, 2022, 01:13:08 AM]


The Viper Simmer by Taipan
[May 18, 2022, 12:14:50 AM]


DCStoF4 by Cupra
[May 10, 2022, 03:52:17 PM]

Author Topic: Losing Keyfile  (Read 406 times)

Offline MailMan

  • Maj. General
  • *****
  • Join Date: May 2009
  • Location: Florida
  • Posts: 363
  • Country: us
  • VP Awards Old Geezer Award: Awarded after 10 years of community service
    • 20th VFW
    • Awards
Losing Keyfile
« on: November 07, 2019, 08:06:41 AM »
Got a weird one here.  I did some SSD upgrade to my PC and reinstalled everything using Win 10 (BMS 4.34).  I got everything working including my networked machine for the MFD's and RWR screens.  I did my normal editing of the key file to program my Cougar and all the switches, rotaries, etc on my center console.  When I am in the controllers screen, I can successfully test all the switches, etc.  Everything calls out the proper function.  When I join a TE and drop into the pit it only works for a few seconds, then I lose all switch and rotary function, including the buttons, hats and rotaries on my Cougar (stick and throttle still work).  Basically I am losing all my DirectX functions.  I have reinstalled BMS and checked Win 10 updates for proper DirectX install.  This one has me stumped, because when I back out of the pit and go back to the controllers screen, everything starts working again.  Help would be appreciated.

Online Red Dog

  • Administrator
  • General
  • *****
  • Join Date: Mar 2004
  • Location: Brussels
  • Posts: 3697
  • Country: be
  • VP Awards 3000+ posts Award: Awarded for achieving over 3000 posts Gold Medal Award: Awarded for special contributions to the community Outstanding Build Award: Awarded for an outstanding pit build Top Poster Award: for those 30 members with most posts Silver Heart Award: Awarded to those showing a real heart for the community and/or it's cause Most Time Online Award: Awarded to those 30 members with most time on the forum Old Geezer Award: Awarded after 10 years of community service
    • CombatSim Checklists
    • Buy me some coffee
    • Awards
Re: Losing Keyfile
« Reply #1 on: November 07, 2019, 10:01:05 AM »
Sounds like a DX device ID getting changed
How many DX ID you have?
Cougar, Leo Bodnar?

Are the callbacks still work when that happens, so it's just DX?

Have a bandit day
Red Dog

Offline MailMan

  • Maj. General
  • *****
  • Join Date: May 2009
  • Location: Florida
  • Posts: 363
  • Country: us
  • VP Awards Old Geezer Award: Awarded after 10 years of community service
    • 20th VFW
    • Awards
Re: Losing Keyfile
« Reply #2 on: November 07, 2019, 04:41:58 PM »
Sounds like a DX device ID getting changed
How many DX ID you have?
Cougar, Leo Bodnar?

Are the callbacks still work when that happens, so it's just DX?


I fixed it Reddog.  Something got messed up in Windows.  I did a reinstall of Windows and now everything works great.  3 Leo Bodnar Boards and my Cougar all working now.  Also using an AIC Center Controller for lights.  I sold off my left and right consoles and am running with just the center console now.  Needed to create room.

 

SimplePortal 2.3.5 © 2008-2012, SimplePortal