collapse

* Who's Online

  • Dot Guests: 2
  • Dot Hidden: 0
  • Dot Users: 2
  • Dot Users Online:

* Recent Topics/Posts

We need some donations for VP to keep it running by Cupra
[December 02, 2022, 05:32:36 PM]


Need Help to grab a place as Beta-tester by Strale
[November 29, 2022, 06:07:57 AM]


Howdy from the Midwest! by Rufus
[November 28, 2022, 08:22:14 PM]


BMS 4.33 issue. by Poppy
[November 24, 2022, 09:05:16 PM]


CPD Software by Mustang 1-1
[November 23, 2022, 10:28:14 AM]

Author Topic: BMS 4.33 issue.  (Read 198 times)

Offline Poppy

  • 1st.LT
  • **
  • Join Date: Jul 2008
  • Location: Saint Francis - Wisconsin
  • Posts: 37
  • Country: us
  • VP Awards Old Geezer Award: Awarded after 10 years of community service
    • Buy me some coffee
    • Awards
BMS 4.33 issue.
« on: November 21, 2022, 06:31:11 PM »
Hello everyone!

I'm trying to get started back again flying falcon after many years away from the hobby, and I installed BMS 4.33 U1 with all the incremental updates up to #5, but when I start the launcher I get an error message as follows:

"Could not open registry key HKLM/Software/Benchmark Sims/Falcon BMS 4.33 U1 error code 2"

I opened regedit, and tried to compare the same registry key with the one on BMS 4.32 which is also installed on the same machine, and looks like the registry key from BMS 4.33 is missing some lines. I also have installed an original version of Falcon 4, since 4.32 and 4.33 will look for it to get installed, but I'm being unable to figure out what's going on, had anyone else in this site ever had the same problem?
Any help you guys can provide will be greatly appreciated! Thank you very much in advance!

Poppy

Offline jjbravo

  • General
  • ******
  • Join Date: Jan 2019
  • Location: California
  • Posts: 1096
  • Country: us
  • Callsign: Wingnut
  • VP Awards Most Time Online Award: Awarded to those 30 members with most time on the forum Top Poster Award: for those 30 members with most posts 1000+ posts Award: Awarded for achieving over 1000 posts Triplet Award: Awarded after 3 years of community service
    • Awards
Re: BMS 4.33 issue.
« Reply #1 on: November 21, 2022, 06:41:58 PM »
Windows registry is a little funky with the 64bit/32bit stuff, did you check under the WOW6432Node? (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node)

Have you considered using  the latest version of BMS 4.36? They just released a new installer which is a lot more convenient. This will also add the firewall and anti-virus exclusions you need to run smoothly.

https://cdn.falcon-bms.com/Downloader/Falcon_BMS_Downloader.zip

John

Offline Poppy

  • 1st.LT
  • **
  • Join Date: Jul 2008
  • Location: Saint Francis - Wisconsin
  • Posts: 37
  • Country: us
  • VP Awards Old Geezer Award: Awarded after 10 years of community service
    • Buy me some coffee
    • Awards
Re: BMS 4.33 issue.
« Reply #2 on: November 21, 2022, 07:03:36 PM »
Hi JJ,

Nope, did not check under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node but what am I supposed to find there or what's supposed to be there? I did consider using 4.36, but I'm running Win& Pro (32 bit) and that's a no no for 4.36, plus I have to get a whole new computer setup for that. At this moment I'm running a Core I5 661 @ 3.33 Ghz with 16 MB of RAM, which is not even close to what 4.36 requires, for that reason is that I'm trying to run 4.32 (Which I have installed and works pretty well), but I wanted to go a step further and see if I could run 4.33 with the same setup. Any ideas?...

Offline jjbravo

  • General
  • ******
  • Join Date: Jan 2019
  • Location: California
  • Posts: 1096
  • Country: us
  • Callsign: Wingnut
  • VP Awards Most Time Online Award: Awarded to those 30 members with most time on the forum Top Poster Award: for those 30 members with most posts 1000+ posts Award: Awarded for achieving over 1000 posts Triplet Award: Awarded after 3 years of community service
    • Awards
Re: BMS 4.33 issue.
« Reply #3 on: November 21, 2022, 07:10:54 PM »
Oh, sorry. If you are running 32 bit windows, you won't have the WOW6432Node node.
Do you have a screenshot of your 4.33 registry entry?

Should look something like this
  [ You are not allowed to view attachments ]  

Looks like it's looking for a specific registry folder : "Falcon BMS 4.33 U1"

Offline Poppy

  • 1st.LT
  • **
  • Join Date: Jul 2008
  • Location: Saint Francis - Wisconsin
  • Posts: 37
  • Country: us
  • VP Awards Old Geezer Award: Awarded after 10 years of community service
    • Buy me some coffee
    • Awards
Re: BMS 4.33 issue.
« Reply #4 on: November 21, 2022, 07:39:20 PM »
Compared to yours, I only have 3 entries on mine, check the attached pic..

Offline jjbravo

  • General
  • ******
  • Join Date: Jan 2019
  • Location: California
  • Posts: 1096
  • Country: us
  • Callsign: Wingnut
  • VP Awards Most Time Online Award: Awarded to those 30 members with most time on the forum Top Poster Award: for those 30 members with most posts 1000+ posts Award: Awarded for achieving over 1000 posts Triplet Award: Awarded after 3 years of community service
    • Awards
Re: BMS 4.33 issue.
« Reply #5 on: November 21, 2022, 07:44:05 PM »
What happens if you change the 5 to 1 in the curPatch?
Do you get a different error?

You might consider re-installing.
See here :https://forum.falcon-bms.com/topic/14677/reinstall-issue-the-registry-issue-bms-4-34-and-4-33-u1
« Last Edit: November 21, 2022, 07:49:33 PM by jjbravo »

Offline Poppy

  • 1st.LT
  • **
  • Join Date: Jul 2008
  • Location: Saint Francis - Wisconsin
  • Posts: 37
  • Country: us
  • VP Awards Old Geezer Award: Awarded after 10 years of community service
    • Buy me some coffee
    • Awards
Re: BMS 4.33 issue.
« Reply #6 on: November 21, 2022, 07:56:05 PM »
No, I didn't try that, but that is gonna be next. Otherwise, I will have to do another dance and reinstall! Anyways, thanks for the suggestions and the link! I'll try them and see what happens, I'll let you know any findings!
Thanks again JJ

Offline Poppy

  • 1st.LT
  • **
  • Join Date: Jul 2008
  • Location: Saint Francis - Wisconsin
  • Posts: 37
  • Country: us
  • VP Awards Old Geezer Award: Awarded after 10 years of community service
    • Buy me some coffee
    • Awards
Re: BMS 4.33 issue.
« Reply #7 on: November 24, 2022, 09:05:16 PM »
Well, I gotta say solving this issue was easier that doing one of the Falcon dances! I just didn't realize that the registry key was pointing to HKLM/software/Benchmark Sims/ Falcon BMS 4.33 (It was missing the U1 at the end) :brickwall: so I opened Regedit again, added the "U1" at the end of the registry key and voila!! It worked! :clap: I want to thank people whom tried to offer some insight on this issue, thank you! Hopefully my mistake will help somebody in the same situation!

Poppy

 

SimplePortal 2.3.5 © 2008-2012, SimplePortal